summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Stapelberg <michael+x200@stapelberg.de>2009-03-11 23:29:37 +0100
committerMichael Stapelberg <michael+x200@stapelberg.de>2009-03-11 23:29:37 +0100
commite76452528ab8dd9c553c26c4b70d157242d16e68 (patch)
tree7a17f84a2dd5ac33f84375a87cafad082aff9eac /debian
parent91672632868a56cb229d3311f7a2b5c86eadbcec (diff)
Add debian/
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control23
-rw-r--r--debian/copyright25
-rwxr-xr-xdebian/rules80
5 files changed, 134 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..d4b2676
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+i3lock (1.0-1) unstable; urgency=low
+
+ * First release
+
+ -- Michael Stapelberg <michael+i3lock@stapelberg.de> Wed, 11 Mar 2009 23:24:01 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..460e852
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,23 @@
+Source: i3lock
+Section: utils
+Priority: optional
+Maintainer: Michael Stapelberg <michael+i3lock@stapelberg.de>
+Build-Depends: debhelper (>= 5), libx11-dev
+Standards-Version: 3.8.0
+Homepage: http://i3.zekjur.net/
+
+Package: i3lock
+Architecture: any
+Priority: optional
+Section: x11
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: a slightly improved version of slock
+ Key features of i3 are correct implementation of Xinerama (workspaces are
+ assigned to virtual screens, i3 does the right thing when attaching new
+ monitors), XrandR support (not done yet), horizontal and vertical columns
+ (think of a table) in tiling. Also, special focus is on writing clean,
+ readable and well documented code. i3 uses xcb for asynchronous
+ communication with X11, and has several measures to be very fast.
+ .
+ Please be aware i3 is primarily targeted at advanced users and developers
+ and that you’re currently trying an alpha version (which may contain bugs).
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..b05115d
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,25 @@
+This Debian package is based on a tarball downloaded from
+http://i3.zekjur.net
+
+MIT/X Consortium License
+
+© 2006-2008 Anselm R Garbe <garbeam at gmail dot com>
+© 2009 Michael Stapelberg <michael+i3lock at stapelberg dot de>
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..79bfde7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,80 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+config.status: configure
+ dh_testdir
+ touch $@
+
+build:
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build
+
+ # Add here commands to clean up after the build process.
+ [ ! -f Makefile ] || $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/wiipdf
+ $(MAKE) DESTDIR=$(CURDIR)/debian/i3lock/ install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+ dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+ dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+# dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install