summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules77
1 files changed, 21 insertions, 56 deletions
diff --git a/debian/rules b/debian/rules
index c35d829..2729083 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,67 +1,32 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# vi: ts=8 sw=8 noet
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-config.status: configure
- dh_testdir
- touch $@
-
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
+DPKG_EXPORT_BUILDFLAGS = 1
+-include /usr/share/dpkg/buildflags.mk
+build: build-stamp
build-stamp:
- dh_testdir
- $(MAKE)
- touch $@
+ dh build
+ touch build-stamp
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- $(MAKE) clean
- dh_prep
- rm -f debian/files
- rm -f debian/i3lock.debhelper.log
+clean:
+ dh clean
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
+install: build install-stamp
+install-stamp:
+ dh install
+ touch install-stamp
- $(MAKE) DESTDIR=$(CURDIR)/debian/i3lock/ install
- mkdir -p $(CURDIR)/debian/i3lock/usr/share/man/man1
- cp i3lock.1 $(CURDIR)/debian/i3lock/usr/share/man/man1
+binary-arch: install
+ dh binary-arch
+binary-indep: install
+ dh binary-indep
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+binary: binary-arch binary-indep
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+override_dh_auto_build:
+ $(MAKE)
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_install:
+ $(MAKE) DESTDIR=$(CURDIR)/debian/i3lock/ install