summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 5 insertions, 17 deletions
diff --git a/debian/rules b/debian/rules
index fa91b71..2955d2a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,15 +29,17 @@ clean:
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) clean
- dh_clean
+ dh_prep
install: build
dh_testdir
dh_testroot
- dh_clean -k
+ dh_prep
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/i3lock/ install
+ mkdir -p $(CURDIR)/debian/i3lock/usr/share/man/man1
+ cp i3lock.1 $(CURDIR)/debian/i3lock/usr/share/man/man1
# Build architecture-independent files here.
@@ -50,25 +52,11 @@ binary-arch: build install
dh_testroot
dh_installchangelogs
dh_installdocs
- dh_installexamples
-# dh_install
-# dh_installmenu
- dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_python
- dh_installinit
-# dh_installcron
-# dh_installinfo
dh_installman
dh_link
-# dh_strip
+ dh_strip
dh_compress
dh_fixperms
-# dh_perl
-# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol